Version: 1.6.0

Packages

ts-engine is made up of family of packages. Whilst for most use cases you'll only need to use @ts-engine/cli, you may sometimes want to install the other packages for things like extending ESLint config or customising your Babel configuration.

@ts-engine/babel-presetThe default Babel preset for ts-engine.
@ts-engine/babel-preset-reactA Babel preset for ts-engine with React support.
@ts-engine/cliCore package providing the ts-engine CLI.
@ts-engine/eslint-configThe default ESLint config for ts-engine.